Ticket

+commit
 

 

 

+example

Part

http://hooze.org/wagn/Restaurant

 

Strangely, was able to do it in sandbox.wagn.org and http://sandwagn.wagn.org/card/edit/fubar

 

Also, There are no foofoo cards, but you get a 500 error when you click on the type submenu under edit:

 

foofoo

 

 


 

 

On RCC, trying to edit some (only ones that there was an attempt to delete?):

http://2009rcc.org/wagn/Silence
http://2009rcc.org/wagn/time_slot

but not other:
http://2009rcc.org/wagn/Session
http://2009rcc.org/wagn/timeslot

...cardtypes returns a 500.

 

I think I fixed some core issues here while working on the user transformations.


I haven't actually tested this, but I think it may have gotten fixed in the process. If not, let's remove the Wagn 1.0 tag (avoid scope creep).

  --Ethan McCutchen.....Mon Jan 26 11:32:07 -0800 2009


some key comments in "better handling" discussion (see top)

  --Ethan McCutchen.....Mon Feb 23 16:31:47 -0800 2009


Just tried to delete http://new.wagn.org/wagn/Setting (after removing the one Setting card). Got connecting to server...done but stayed in edit mode. Reloading the page shows it still exists. Clicking Edit then gives a 500 error.

http://new.wagn.org/wagn/Currency and http://new.wagn.org/wagn/Percentage are slated for deletion as well; may be a good test bed.

  --John Abbe.....Fri Feb 27 12:17:02 -0800 2009


Make sure to test renaming as well, which has also returned a 500 at times.

  --John Abbe.....Sat Apr 04 11:08:46 -0700 2009


This is tricky, because I'm seeing different behavior locally than what I'm seeing on pinz and ang, but I just took a stab and deployed it to pinz and deleted one cardtype from indecks.net and it seemed to work. It needs a lot more testing, of course, but it's nice to have progress on this!

  --Ethan McCutchen.....Sun Apr 26 22:52:26 -0700 2009


As of now, the case seems to be that you *can* remove the cardtypes, but it takes two efforts. The first removes the extension, and the second removes the actual card. (Note, in dev mode on a local copy, it's all deleting smoothly in one try). We were seeing some problems before with cardtype's edit mode breaking when they lacked an extension, but that's been fixed.

You can also now change types to and from "Cardtype", though extensions are not properly handled (this problem is ticketed separately as add extensions when cardtype is changed

I suggest closing this ticket and creating a new, low-priority one to fix the issue of having to take two tries to delete a cardtype. (post 1.0)

  --Ethan McCutchen.....Wed Apr 29 22:07:45 -0700 2009


delete Cardtypes with just one delete

  --John Abbe.....Wed Apr 29 22:45:16 -0700 2009


nice! shall we close this, then?

  --Ethan McCutchen.....Wed Apr 29 23:44:24 -0700 2009