Upgrading from Wagn to Decko broke theming

Support Ticket

+status
open
 
+issue

I upgraded my wagn from the wagn-1.21.0 gem to the decko-0.4.1 gem according to the Updating instructions, and migrations reported success, but rendering of page styles and controls is broken now.  A screenshot of my homepage (the "Welcome" card) is attached, and the following appeared in log/production.log (with my home IP address redacted) while loading the page:

Started GET "/" for [REDACTED_IP_ADDRESS] at 2018-05-28 20:51:41 -0700
Processing by CardController#read as HTML
reading file: /home/arielmt/.gems/gems/card-1.94.1/mod/bootstrap/lib/stylesheets/style_bootstrap_cards.scss
reading file: /home/arielmt/.gems/gems/card-1.94.1/mod/bootstrap/vendor/bootstrap/scss/_functions.scss
reading file: /home/arielmt/.gems/gems/card-1.94.1/mod/bootstrap/vendor/bootstrap/scss/_variables.scss
reading file: /home/arielmt/.gems/gems/card-1.94.1/mod/bootstrap/vendor/bootstrap/scss/mixins/_breakpoints.scss
  Rendering text template
  Rendered text template (0.0ms)
Completed 200 OK in 1634ms (Views: 1.7ms | ActiveRecord: 19.5ms)
Started GET "/files/~3462/1527565902." for [REDACTED_IP_ADDRESS] at 2018-05-28 20:51:43 -0700
Processing by CardController#read as HTML
  Parameters: {"view"=>"bad_address", "id"=>"files/~3462/1527565902."}
reading file: /home/arielmt/.gems/gems/card-1.94.1/mod/bootstrap/lib/stylesheets/style_bootstrap_cards.scss
reading file: /home/arielmt/.gems/gems/card-1.94.1/mod/bootstrap/vendor/bootstrap/scss/_functions.scss
reading file: /home/arielmt/.gems/gems/card-1.94.1/mod/bootstrap/vendor/bootstrap/scss/_variables.scss
reading file: /home/arielmt/.gems/gems/card-1.94.1/mod/bootstrap/vendor/bootstrap/scss/mixins/_breakpoints.scss
Started GET "/files/~3462/1527565902..js" for [REDACTED_IP_ADDRESS] at 2018-05-28 20:51:43 -0700
Processing by CardController#read as JS
  Parameters: {"explicit_file"=>true, "id"=>"~3462", "rev_id"=>"1527565902."}
attachment_format issue: undefined method `extensions' for nil:NilClass
  Rendering text template
  Rendered text template (0.0ms)
Completed 404 Not Found in 83ms (Views: 1.5ms | ActiveRecord: 6.0ms)
  Rendering text template
  Rendered text template (0.0ms)
Completed 404 Not Found in 1369ms (Views: 0.7ms | ActiveRecord: 16.6ms)
Started GET "/files/~3462/1527565902..js" for [REDACTED_IP_ADDRESS] at 2018-05-28 20:51:44 -0700
Processing by CardController#read as JS
  Parameters: {"explicit_file"=>true, "id"=>"~3462", "rev_id"=>"1527565902."}
attachment_format issue: undefined method `extensions' for nil:NilClass
  Rendering text template
  Rendered text template (0.0ms)
Completed 404 Not Found in 68ms (Views: 0.7ms | ActiveRecord: 4.3ms)
Started GET "/files/~103/2114-small.png" for [REDACTED_IP_ADDRESS] at 2018-05-28 20:51:44 -0700
Processing by CardController#read as PNG
  Parameters: {"explicit_file"=>true, "id"=>"~103", "rev_id"=>"2114", "size"=>"small"}
Sent file /home/arielmt/thornton2.com/files/103/2114-small.png (0.4ms)
Completed 200 OK in 11ms (ActiveRecord: 0.0ms)

The directory files/3462/ exists, but it's empty.

Any help is appreciated.  Thank you.

+screenshot
Upgrading from Wagn to Decko broke theming+screenshot