Support Ticket

+status
+tags
 

Did self installation. I can get the url to show the Wagn icon but it page display is blank page no matter what I do.  Dying of dysentery. Please help.

Connecting to database specified by database.yml

Started GET "/admin/setup" for 207.178.105.123 at 2013-03-22 10:25:14 -0500

Processing by AdminController#setup as HTML

exception = NoMethodError: private method `initialize_dup' called for #<Card###30488280[no code:](){new:!loaded:nil}>

Completed 500 Internal Server Error in 11ms

 

NoMethodError (private method `initialize_dup' called for #<Card###30482980[no code:](){new:!loaded:nil}>):

  lib/cardlib/templating.rb:19:in `template'

  app/models/card.rb:133:in `get_type_id'

  app/models/card.rb:105:in `initialize'

  app/models/card.rb:41:in `new'

  app/models/card.rb:41:in `new'

  app/controllers/application_controller.rb:140:in `block in <class:ApplicationController>'

 

 

Started GET "/" for 207.178.105.123 at 2013-03-22 10:25:19 -0500

Processing by CardController#read as HTML

Redirected to http://applianz8.appeazy.com:3000/admin/setup

Filter chain halted as :load_id rendered or redirected

Completed 302 Found in 1ms (ActiveRecord: 0.0ms)

 

Are you using Ruby 2.0 by any chance?  I suspect it's related to this:  https://github.com/rails/rails/pull/8405

 

We haven't tested in Ruby 2.0 yet (I think it was just released last month).  We will definitely be supporting it, and that particular problem looks like a very easy fix, but the immediate route to getting going is to use ruby 1.9.x.

 

We'll try to get stuff patched in a hurry; thanks for the heads up.  Sorry about the dysentery.

 

-e


still not tested in 2.0, but this particular issue is fixed.

  --Ethan McCutchen.....2013-04-03 15:26:09 +0000