Support Ticket

+status
+tags
 
+issues

I am trying to install Wagn on apache with phusionpasenger.

 

I am getting the message

 

Further information about the error may have been written to the application's log file. Please check it in order to analyse the problem.

Error message: The path `/......./ruby/gems/gems/wagn-dev` does not exist. (Bundler::PathError) Exception class: PhusionPassenger::UnknownError

I didn't think that wagn-dev was required.

What am I doing wrong?

Thanks,

Karl

 

Hi Karl,

 

That's correct, you should not need wagn-dev. It should never be used in production, and in fact, we're moving away from that gem altogether.

 

What version of wagn are you using?

 

My first guess is that it is listed in your Gemfile (there is a file with that name in the root directory of your instance). If so, you can just delete that line or comment it out. If that's not the case, would you be willing to copy to paste the contents of that file here?

 

By the way, if you've not already found this, you may find the docs on running Wagn in production very helpful.

--Ethan McCutchen.....2014-07-14 18:16:14 +0000

Thanks, I must have done something wrong, maybe made the symbolic link to the wrong place or something. I ended up just deleting everything and starting over. A friend and I did get it installed after that.

--henselkp.....2014-08-21 20:45:25 +0000