Samples Blog contact support

WARNING: Almost everything below is obsolete!


We've left the discussion here for archival purposes, but Wagn's architecture and installation process changed dramatically with the 1.8 release, and pretty much nothing that follows is relevant any more!


How to turn off all the debug/sql/etc and speed this guy up?

  --Ross J. McCarthy.....Fri May 01 16:45:32 -0700 2009

sounds like you're running rails in development mode, and you want to run in production. try ./script/server -e production

  --Lewis Hoffman.....Sun May 03 21:05:01 -0700 2009


Getting this error:

DevUbuntu ~/public_html/wikis/wagn: rake RAILS_ENV=production asset:packager:build_all
(in /home/jeff/public_html/wikis/wagn)
rake aborted!
Don't know how to build task 'asset:packager:build_all'

(See full trace by running task with --trace)
DevUbuntu ~/public_html/wikis/wagn: rake -T asset
(in /home/jeff/public_html/wikis/wagn)
rake doc:plugins:asset_packager # Generate documentation for the asset_packager plugin
DevUbuntu ~/public_html/wikis/wagn: rake RAILS_ENV=production wagn:create
(in /home/jeff/public_html/wikis/wagn)
rake aborted!
Error loading cardtypes/file.rb: uninitialized constant Card::File::CardFile

(See full trace by running task with --trace)

  --Jeff Schoolcraft (Not signed in).....Sun May 17 04:11:21 -0700 2009

I get a bunch of errors running the rake create but I am familiar with PostgreSQL and did:

createdb wagn_development

but I still have problems when I run:

rake wagn:create

I get:


(in /home/rails/wagn-0.13.0)

Couldn't drop wagn_development : #

wagn_development already exists

-- create_table("card_files", {:force=>true})

rake aborted!

undefined method `quote_ident' for PGconn:Class

Has anyone had WagN working with PostgreSQL?



  --Anonymous (Not signed in).....Tue May 26 03:21:48 -0700 2009

Getting this error on a Windows box (I know, but it's a work box):

RuntimeError (Error loading cardtypes/file.rb: undefined method `has_attachment' for # ):


/app/models/card.rb:41:in `each'



  --Noah Stern (Not signed in).....Thu Jun 11 08:20:27 -0700 2009

If anyone else runs into the issues Jeff Schoolcraft did, make sure you've done the git submodule update on your server.

  --Mike Gunderloy (Not signed in).....Thu Jun 11 15:19:18 -0700 2009

Same as Noah, but on an Ubuntu box:


RuntimeError (Error loading cardtypes/file.rb: undefined method `has_attachment' for # ):


/app/models/card.rb:41:in `each'


The attachment_fu plugin directory is empty. This should do the trick:


./script/plugin install --force


But then another error occurs. Upon closer inspection, all plugin dirs appear to be empty!

  --Onno (Not signed in).....Sun Jun 14 04:10:27 -0700 2009

Okay, upon even closer inspection, only asset_packager and attachment_fu are empty. Reinstall both (using --force) and you're good to go!

  --Onno (Not signed in).....Sun Jun 14 04:15:41 -0700 2009

Any clarification on when Wagn will run on newer versions of Rails? I'm hoping to run in a hosted environment, but I can't just install a different version of rails, since it isn't my server. I'd love to get in on it, but have to wait until we can use at least Rails 2.3.2.

  --Sam (Not signed in).....Thu Jul 02 15:01:58 -0700 2009

We're expecting it to run on rails 2.3.x by the next release. Traditionally we've lagged a little behind on updating to the latest rails versions, but we're getting quicker :)

  --Ethan McCutchen.....Fri Jul 03 08:41:34 -0700 2009

@Sam In the latest packages on rubyforge we include rails 2.2 in /vendor, you could check if that will work on your shared host, which wouldn't require you to install rails 2.2 on the system.

  --Lewis Hoffman.....Fri Jul 03 12:28:14 -0700 2009

I recently did a local install via git and had to install the rspec gem as rake bombed without it. Other than this small issue I got Wagn to install on kubuntu which doesn't have the best ruby/rails setup

  --bserviss.....Mon Jul 06 16:39:04 -0700 2009

I'm trying to run wagn on - I got it running on port 3000 ok when I start it up with script/server - but I want to run with virtualhosts on apache. so I have a mongrel cluster running on 2 ports and I have configured the virtualhosts. When it fires up I would expect it to be visible on my wagn.apacheurl and even when I change the url in wag.rb to my apache url (with or without specifying port 80) I still get a page not found. I think this is something to do with how the url works in wagn.rb - also the ports my mongrel cluster runs on are not accessible from the front of the server - they are closed for security so only apache on port 80 is open. Any ideas where I'm going wrong?

  --Kingsley (Not signed in).....Sat Jul 11 03:01:20 -0700 2009

Ah I got it working - I had to add a socket line into database.yml for the mysqld.sock and also I had a typo in the base url in wagn.rb

  --Kingsley (Not signed in).....Sat Jul 11 03:19:03 -0700 2009

It might be useful for others to note that they way to install the asset_packager plugin is to:


./script/plugin install --force git://

  --Dylan McNamee.....Wed Jul 29 15:21:00 -0700 2009

To get wagn running on a different port, I found that I had to edit the wagn.rb file's port, as well as pass the port on the command line:


./script/server -p 8000


This, along with using many of the hints above, let me get wagn running on the vanilla "Ruby on Rails" JumpBox.

  --Dylan McNamee.....Wed Jul 29 15:26:32 -0700 2009



installation instructions don't work or are missing a file


after git clone && cd wagn


rake gems:install

no such file to load -- spec/rake/spectask


rake wagn:create

no such file to load -- spec/rake/spectask


don't know what is going on

  --Anonymous (Not signed in).....Mon Jul 27 22:29:32 -0700 2009

Regarding the 'spec/rake/spectask' errors, install the 'rspec' and 'rspec-rails' gems and it should go away.

  --Shane (Not signed in).....Thu Jul 30 12:04:02 -0700 2009

For some reason, I can't get the image and file uploads to work correctly in either my development or my production instance. I've gone back through everything above, but it still doesn't want to work. It fails silently in the interface, and I get the following sorts of errors in my log file:


ActionController::UnknownAction (No action responded to 0000. Actions: after, auto_link, before, build_object, card, card_path, card_title_span, card_url, cards, collection_url_prefix, concat, connect_icon, connected_icon, connector_function, context, create, current_cycle, current_model, current_model_name, current_object, current_objects, cycle, destroy, discard_locations_for, edit, edit_object_path, edit_object_url, ensure_parent_exists, exception_status, excerpt, flexlink, highlight, index, instance_variable_name, link_to_connector_update, link_to_page, load_location, load_object, load_objects, load_parent_object, location_history, name_in_context, namespaces, nested_object_path, nested_object_url, new, new_object_path, new_object_url, notice, notice=, object_parameters, object_path, object_url, objects_path, objects_url, page_icon, parent?, parent_class_name, parent_model, parent_name, parent_names, parent_object, parent_path, parent_url, pieces_icon, plural?, plural_action?, pluralize, polymorphic_parent?, polymorphic_parent_name, previous_location, render_404, render_500, render_card_errors, render_exception, render_fast_404, requesting_ajax?, requesting_javascript?, rescue_action, reset_cycle, response_for, sanitize, sanitize_css, save_failed!, save_location, save_succeeded!, save_succeeded?, scope, set_default_flash, set_default_redirect, show, simple_format, singular?, singular_action?, slot, slot=, strip_links, strip_tags, truncate, update, url_for_card, url_for_page, url_helper_prefix, and word_wrap):


After this it stack traces through the filters and into the app server code. I get similar errors in both development and production and using both mongrel and passenger. Any ideas? Thanks,

  --Anonymous (Not signed in).....Mon Aug 03 12:14:49 -0700 2009

Getting this error:

RuntimeError (Error loading cardtypes/file.rb: undefined method `has_attachment' for # ):


app/models/card.rb:43:in `each'


app/controllers/application_controller.rb:56:in `per_request_setup'




Processing ApplicationController#index (for at 2009-08-16 23:37:55) [GET]


LoadError (Expected E:/ror_project/wagn/app/models/card/base.rb to define Card::Base):


lib/exception_system.rb:46:in `exception_status'

lib/exception_system.rb:5:in `rescue_action'


/! FAILSAFE /! Sun Aug 16 23:37:55 +0800 2009

Status: 500 Internal Server Error

Expected E:/ror_project/wagn/app/models/card/base.rb to define Card::Base

c:/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.3/lib/active_support/dependencies.rb:426:in `load_missing_constant'


  --liang (Not signed in).....Sun Aug 16 08:43:14 -0700 2009

@all the rspec dependency should be fixed in the latest release.


@liang are you sure the submodule step worked correctly?

git submodule update --init

check to see that vendor/plugins/attachment_fu holds the plugin files.


@Anonymous file/image error: check permissions. the ruby process needs write access to the directory where the files go-- requests for missing images could cause the error you're seeing.

  --Lewis Hoffman.....Mon Aug 17 16:10:44 -0700 2009

It worked for me, thanks!

  --liang (Not signed in).....Wed Aug 19 05:24:48 -0700 2009

Lewis, thanks for the suggestion. After digging further, it looks like I may be missing something or doing something wrong. The images, which aren't showing up in the site, are being stored in the public/card_images folder. However, the html that displays from the view adds an _medium to the filename. For example, if I upload foo.jpg, then the view tries to display foo_medium.jpg. My guess is that wagn is using something like ImageMagik to generate thumbnails, but I have ImageMagik/Rmagik installed, and I didn't see any specific requirements in the installation notes for anything different. Do you have any idea as to what I'm missing?

  --Anonymous (Not signed in).....Wed Aug 19 09:31:57 -0700 2009

@Anonymous - sounds like you're on the right track- Wagn does depend on image thumbnailing, we use ImageScience on our servers but it should work with any of the three listed here:

  --Lewis Hoffman.....Thu Aug 20 17:31:12 -0700 2009

I figured it out, and it turns out that there is a weird library issue with RMagick/ImageMagick on RHEL 5. Once I fixed that, image upload worked like a charm.

  --Anonymous (Not signed in).....Tue Aug 25 13:07:23 -0700 2009

C:wagn>ruby script/plugin install --force

Plugin not found: [""]


But the url is good

  --cw (Not signed in).....Thu Aug 27 22:07:16 -0700 2009

deleted the existing vendor/plugins/attachment_fu empty file and the install was successful....

  --cw (Not signed in).....Fri Aug 28 07:12:27 -0700 2009

For those getting stuck while trying to install it on OS X, with the message "Can't connect to local MySQL server through socket '/tmp/mysql.sock'", try to replace "localhost" by "" in database.yml : it did the trick for me :-)

  --dieudo.....Mon Sep 07 14:00:11 -0700 2009

How does someone turn on Ruby and/or Script cards? (see Missing Internal Type Card Behavior)

  --John Abbe.....Sun Sep 27 11:24:38 -0700 2009

Shouldn't we maybe have a separate page for more in-depth coverage of running wagn servers? I'm wanting to know what is the best practice for production servers, and going through stuff and not knowing the where the baseline is for this.


For example, comments in .htaccess indicate I should have a full path to dispatcher, and it isn't clear whether this is a support script, or something I have to make. dispatch.cgi is linked in with a rel path, but other comments suggest I want fcgi.


I found some docs with google, and saw I might want:

FastCgiServer /var/web/typo/public/dispatch.fcgi -idle-timeout 120

-initial-env RAILS_ENV=production -processes 2

In my apache config.

  --Gerry Gleason.....Mon Sep 28 06:53:40 -0700 2009

Yes, that sounds right to me. We may not have much time for building out that page this week, but if you'd like to start framing it out, posing some key questions, etc, that would be awesome.

  --Ethan McCutchen.....Mon Sep 28 08:18:03 -0700 2009

I´m trying to install this on postgres in Ubuntu but I´m unfamiliar with postgres.


rake wagn:create yields:


Couldn't drop wagn_development : #/<Mysql::Error: Acess denied for user ´user´@´localhost´ (using password: YES)/>

  --Brandon Quinn.....Wed Oct 21 21:34:01 -0700 2009

Hey Brandon. Have a look at config/database.yml. Does the login information look right for your database?

  --Ethan McCutchen.....Wed Oct 21 21:50:29 -0700 2009

Even after spending forever in database.yml I didn't realize my mistake until your response. My adapter was set to mysql instead of postgresql. After installing a couple more prereq's I got my Wagn running.



  --Brandon Quinn.....Thu Oct 22 16:27:38 -0700 2009

I can't get the ./script/server -d switch to work. It says it's starting, but my browser cannot find the page. If I don't use the -d switch everything works great. Any suggestions?

  --ross (Not signed in).....Mon Oct 26 09:36:53 -0700 2009

I just checked out wagn today. When I run rake db:migrate, I got error below, please advise what I should do to work around this.


no such file to load -- lib/schema_version_jump_hack


Thank you.

  --gcao.....Wed Nov 25 12:49:09 -0800 2009

Never mind. I should have run 'rake wagn:create' instead.

  --gcao.....Wed Nov 25 12:53:24 -0800 2009

=> Booting WEBrick

=> Rails 2.3.5 application starting on

=> Call with -d to detach

=> Ctrl-C to shutdown server

[2009-12-02 08:01:40] INFO WEBrick 1.3.1

[2009-12-02 08:01:40] INFO ruby 1.8.7 (2009-06-12) [i686-linux]

[2009-12-02 08:01:45] INFO WEBrick::HTTPServer#start: pid=2371 port=3000


how to change the 0.0.0. to

i already changed the wagn.rb base url to

  --neonlinux (Not signed in).....Tue Dec 01 16:04:24 -0800 2009

this is the error msg ...

Application error


Oh, Man. You found a hitch in the Wagn


now i already noticed above that this Rails 2.3.5 might be too new...

is this correct?

  --neonlinux (Not signed in).....Tue Dec 01 16:11:10 -0800 2009

What does the prototype.js package do? I had to move in below jquery for captcha to work on one of my servers. It was throwing a security error.

  --Gerry Gleason.....Sun Dec 06 13:56:38 -0800 2009

I just checked out wagn today. When I run rake db:migrate, I got error below, please advise what I should do to work around this.

no such file to load -- lib/schema_version_jump_hack

Thank you.

  --Danilo (Not signed in).....Thu Dec 17 05:09:13 -0800 2009

@Danilo, I think this means your schema didn't get initialized properly. try running

/* rake wagn:create */ again and watch closely for errors there.

  --Lewis Hoffman.....Thu Dec 17 09:25:22 -0800 2009

er, it's my first time trying out ruby on rails on my ubuntu machine


but i think i did fine with the install of everything


but now after i run srcipt/server and it seems to be starting, when i point my browser to /wagn/public I get this message:

Application error

Rails application failed to start properly


help please?

  --Lucy Perry.....Mon Dec 21 12:15:11 -0800 2009

Lucy can you tell us any more about the error message? does it show up in the console where you started the server? does it show up in the error log /log/development.log ? are you pointing to localhost:3000?

  --Lewis Hoffman.....Mon Dec 21 12:41:44 -0800 2009

Hi Lewis, thanks, the last thing in development.log is



as for pointing to localhost:3000, my machine is apparently not set up so that 3000 does anything in this case, but i do have wagn installed under my localhost web directory with all my other (php-based) web apps. Sorry if I've misunderstood something basic here


My apache log says:

[Mon Dec 21 21:39:32 2009] [error] [client] /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/whiny_nil.rb:52:in `method_missing': undefined method `env_table' for nil:NilClass (NoMethodError)

[Mon Dec 21 21:39:32 2009] [error] [client] from /usr/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/cgi_process.rb:22:in `__send__'

[Mon Dec 21 21:39:32 2009] [error] [client] from /usr/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/cgi_process.rb:22:in `dispatch_cgi'

[Mon Dec 21 21:39:32 2009] [error] [client] from /usr/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/dispatcher.rb:101:in `dispatch_cgi'

[Mon Dec 21 21:39:32 2009] [error] [client] from /usr/lib/ruby/gems/1.8/gems/actionpack-2.3.5/lib/action_controller/dispatcher.rb:27:in `dispatch'

[Mon Dec 21 21:39:32 2009] [error] [client] from /var/www/public_html/wagn/public/dispatch.cgi:10

[Mon Dec 21 21:39:32 2009] [error] [client] Premature end of script headers: dispatch.cgi


I appreciate any guidance, and if I'm making some basic error in my setup maybe you can point me to the proper ruby on rails docs



  --Lucy Perry.....Mon Dec 21 12:54:18 -0800 2009

ok, now working on why localhost:3000 does not do anything, since when i start wagn server it definitely says it's

starting on

  --Lucy Perry.....Mon Dec 21 13:26:47 -0800 2009

but i still think there is another problem as noted in the apache log above, and i've not been able to make any headway on that one at all

  --Lucy Perry.....Mon Dec 21 13:27:53 -0800 2009

hello admin, I found your blog from yahoo and read a few of your other posts.They are awesome. Please keep it up!!


(copy xbox 360 games | wow gold guide | xbox 360 repair guide )

  --Jeff888 (Not signed in).....Fri Dec 25 22:17:19 -0800 2009

Hi again, well my ruby-on-rails install is behaving better now and localhost:3000 does indeed bring up wagn app but now I have error messages in my browser, beginning with:


NoMethodError in Admin#setup


Showing app/views/builtin/_head.rhtml where line #20 raised:


undefined method `stylesheet_link_merged' for #


Any clues? Is this a wagn problem or a problem with my ROR setup? I can give you contents of dev log if you want. Last line is: Rendering rescues/layout (internal_server_error)


Thanks if you can help at all.

  --Lucy Perry.....Tue Dec 29 02:50:16 -0800 2009

sorry for all the messages but I tried running

git submodule update --init

but all I get is a "usage" response from git:

Usage: /usr/bin/git-submodule [--quiet] [--cached] [add [-b branch]|status|init|update] [--] [ ...]

  --Lucy Perry.....Tue Dec 29 03:10:46 -0800 2009

ok got it working now, had to manually install the plugins

  --Lucy Perry.....Tue Dec 29 05:08:52 -0800 2009

@Lucy maybe try git submodule init ; git submodule update (ie. separately). Sorry I couldn't help more with those initial errors-- Glad you got it working!

  --Lewis Hoffman.....Tue Dec 29 10:39:47 -0800 2009

can someone help me set this up on my Dreamhost account?

  --bhhenry (Not signed in).....Wed Feb 24 18:42:51 -0800 2010

using the Bitnami Ruby stack on Mac OS 10.4 PPC:

When I get to the step "rake gems:install" it says "running without hoptoad" then "gem install uuid", then stops with the message:

/ruby/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb:232: warning: getc is obsolete; use STDIN.getc instead

It doesn't even toss me back to writing another command, it just stops blank, so I ctrl-c to abort it.

What's up? What can I do?

TIA ~ Patrick

  --Patrick Gibbs.....Wed Mar 10 22:09:31 -0800 2010

When I do "gem install hoptoad_notifier" it replies "ERROR: While executing gem ... (RuntimeError) Marshal.load reentered at marshal_load"


I get the same errors whether I download from RubyForge or use Git. Perhaps this is a Bitnami error? Though I encountered similar difficulty with a TonidoPlug running Ubuntu back in August.

  --Patrick Gibbs.....Wed Mar 10 22:18:34 -0800 2010

so, 1) it should be possible to run without hoptoad. at the moment you can have gems:install skip that one if you set the env variable RUN_CODE_RUN. you'll get the "running without hoptoad" message but that's fine. 2) is the error getc error coming from the UUID gem install? is that the thing that's hanging? I'd suggest install the uuid and json gems by hand and see if that goes ok. if so you may be able to just continue on to the next step in the install.

  --Lewis Hoffman.....Thu Mar 11 18:36:42 -0800 2010

The same error comes when I do gem install uuid. I didn't try the set env thing.


I think it's a Bitnami error so I posted on their forum:


The error comes at line 232 in spec_fetcher.rb. Here are lines 231-238 of that file:

specs = begin

Marshal.load spec_dump

rescue ArgumentError

spec_dump = @fetcher.fetch_path spec_path

loaded = true


Marshal.load spec_dump


  --Patrick Gibbs.....Thu Mar 11 18:54:08 -0800 2010

huh, that does seem like a problem with uuid gem on that platform. If it's a big pain to get that fixed, I think there is another library UUIDTools, you could try installing that and replace in the Wagn code with whatever the UUIDTools equivalent is. And if that works well we'd be happy to take a patch-- I have the sense UUIDTools maybe be slightly more commonly used-- so I'd be open to switching libraries, just not likely to get to that soon left to my own devices.

  --Lewis Hoffman.....Fri Mar 12 09:53:09 -0800 2010

This is my configuration :
 * Existing installation
   * Win XP
   * MySQL 5.1 
 * New installation in order to run "wagn" on my laptop (start with ruby/rails)
   * ruby 1.9.1 installed
   * ruby gems 1.3.6 installed
gem install rails --include-dependencies --no-http-proxy
   * rail 2.3.5 installiert (see above)
   * Try first tutorial [ | tutorial]
   * created example ror/Bookmarks 
   * "gem install mysql" had to be installed in order to make first example work.
 * ruby/Rails generic installation done. Now continue wagn specific installation
   * Choose "Option B: Install via Git (recommended)"

   1. Get the source
      git clone git://
      cd wagn; git submodule update --init
   2. In the config directory:
      copy sample_database.yml to database.yml
      copy sample_wagn.rb to wagn.rb
   3. configure config/database.yml for your database.
   4. run rake gems:install (See note about rspec below)
   5. run rake wagn:create
   6. run ./script/server

   * mysysgit installed "Git-"
   * Steps 1 to 5 all fine. Steps 1, 4 and 5 printed some logs on console which looked plausible (no " ... ERROR ... FAILURE ..." occurences). Double check with "MySQL Query Browser" looks nice (tables created and some of them populated).
   * step 6 : run ./script/server
   * popup apears "Anwendung konnte nicht Starten weil msvcrt-ruby1.8.dll nicht gefunden wurde" (english: "application could not start cause msvcrt-ruby1.8.dll not found") click ahead with "OK"-button 
C:Programmewagngithere>ruby script/server
=> Booting WEBrick
=> Rails 2.3.5 application starting on
C:/Programme/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.5/lib/rails/gem_dependency.rb:119:Warning: Gem::Dependency#version_requirem
ents is deprecated and will be removed on or after August 2010.  Use #requirement
C:/Programme/wagngit/here/lib/chunks/uri.rb:77: warning: encoding option is ignored - N
C:/Programme/wagngit/here/lib/chunks/uri.rb:182: warning: encoding option is ignored - N
=> Call with -d to detach
=> Ctrl-C to shutdown server
[2010-05-16 17:54:07] INFO  WEBrick 1.3.1
[2010-05-16 17:54:07] INFO  ruby 1.9.1 (2010-01-10) [i386-mingw32]
[2010-05-16 17:54:07] INFO  WEBrick::HTTPServer#start: pid=3444 port=3000
   * point browser to [http://localhost:3000/] raises following log on console (and shows simmilar infomation in browser)
----------- Wagn Initialization Complete -----------

Processing CardController#index (for at 2010-05-16 17:56:43) [GET]
Couldn't create cache directory: localhost:3000/development/set-d1782270-3dd1-012d-52ef-001742717f26/*home (cannot generate tempfi
le `C:/Programme/wagngit/here/tmp/cache/*home3444-9.cache')
Couldn't create cache directory: localhost:3000/development/set-d1782270-3dd1-012d-52ef-001742717f26/*home (cannot generate tempfi
le `C:/Programme/wagngit/here/tmp/cache/*home3444-9.cache')
Rendering template within layouts/application
Couldn't create cache directory: localhost:3000/development/set-d1782270-3dd1-012d-52ef-001742717f26/home+*self+*layout (cannot ge
nerate tempfile `C:/Programme/wagngit/here/tmp/cache/home+*self+*layout3444-9.cache')

Couldn't create cache directory: localhost:3000/development/set-d1782270-3dd1-012d-52ef-001742717f26/basic+*type+*layout (cannot g
enerate tempfile `C:/Programme/wagngit/here/tmp/cache/basic+*type+*layout3444-9.cache')
Couldn't create cache directory: localhost:3000/development/set-d1782270-3dd1-012d-52ef-001742717f26/*favicon (cannot generate tem
pfile `C:/Programme/wagngit/here/tmp/cache/*favicon3444-9.cache')

.... cut (these kind of messages above 20 times) .....

ActionView::TemplateError (can't convert nil into String) on line #5 of app/views/views/_open.rhtml:
2:      <%= slot.header %>
3: <% end %>
5: <%= slot.wrap_content( slot.render(:expanded_view_content) ) %>
7: <%= slot.notice %>
8: <% if card.ok?(:comment) %> <%#and !card.hard_template %>

    app/models/card/basic.rb:25:in `block in table_of_contents'
    app/models/card/basic.rb:13:in `gsub!'
    app/models/card/basic.rb:13:in `table_of_contents'

Rendering rescues/layout (internal_server_error)

Whats the problem ???
  * Is ruby 1.9.1 to new? "msvcrt-ruby1.8.dll missing" might sugest that ? How to wind your ruby/rails installatio back to the past ???
  * Is this rspec-gem missing as some discusion here suggested ??


Thanks for any suggestions


--Norman.....Sun May 16 09:33:16 -0700 2010

  * installed rspec gem
<<C:Programmewagngithere>gem install rspec>>  looks OK 
  * checking the installation on files system
<<C:Programmewagngithere mpcachelocalhost.3000developmentset-d1782270-3dd1-012d-52ef-001742717f26>> several *.cache files
  note the difference "localhost.3000"-directory exists and in errors above "localhost:3000"-directory apears in path ???
gem install uuid
gem install hoptoad_notifier  
C:Programmewagngithere>gem install uuid
Successfully installed uuid-2.3.1
1 gem installed
Installing ri documentation for uuid-2.3.1...
Updating class cache with 1509 classes...
Installing RDoc documentation for uuid-2.3.1...

C:Programmewagngithere>gem install hoptoad_notifier
Successfully installed hoptoad_notifier-2.2.2
1 gem installed
Installing ri documentation for hoptoad_notifier-2.2.2...
Updating class cache with 1509 classes...
Installing RDoc documentation for hoptoad_notifier-2.2.2...

not much better

  --Norman.....Sun May 16 09:33:53 -0700 2010



Could this be a permission problem? It sounds like the Wagn process isn't able to run the proper cache files for some reason. In Unix that's almost always permissions, I'm a little fuzzier on Windows.


If you're just wanting to try it out, running a single process, you skip the cache files by running the cache in memory:

in environment.rb set config.cache_store = :memory_store


However, we have not updated to ruby 1.9. Others have reported some problems, so ymmv.


If you want to install multiple version of ruby at once, try Pik:

  --Lewis Hoffman (Not signed in).....Sun May 16 11:02:56 -0700 2010

Dear Lewis,


Thank you. Annother step forward.


I did the edit :

in environment.rb set config.cache_store = :memory_store

... and indeed the following error-messages disappear


Couldn't create cache directory: localhost:3000/development/set-d1782270-3dd1-012d-52ef-001742717f26/*home (cannot generate tempfi

le `C:/Programme/wagngit/here/tmp/cache/*home3444-9.cache')

... similar 20 times


there seems to be a security problem

trying singup a new user in order to start working i get the following output in browser

 Recaptcha::RecaptchaError in Account#signup

Showing app/views/account/signup.rhtml where line #43 raised:

No public key specified.

Extracted source (around line #43):

40:           <div class="open-content">
41:             <%= slot.render :edit %>
42:         </div>
43:               <%= slot.full_captcha %>
44:           <div class="submit-tag">
45:             <%= submit_tag 'Submit' %>
46:         </div>

RAILS_ROOT: C:/Programme/wagngit/here
Is it necessary to generate with help of some crypto tool a public/private key pair ??

  --Norman.....Tue May 18 12:50:03 -0700 2010

I've been trying to install wagn, but I'm seeing these errors when I start the server:


-jailshell-3.2$ ./script/server

=> Booting Mongrel

=> Rails 2.3.8 application starting on

/home/jkelfer1/ruby/gems/gems/macaddr-1.0.0/lib/macaddr.rb:49:in `addr': all of /sbin/ifconfig /bin/ifconfig ifconfig ipconfig /all failed (RuntimeError)

from /home/jkelfer1/ruby/gems/gems/uuid-2.3.1/lib/uuid.rb:208:in `initialize'




any ideas?

  --Ray (Not signed in).....Sat Jun 05 17:22:44 -0700 2010

OK it seems my host does not allow access to ifconfig, among other binaries the gem tries. using uuidtools instead seems to do the trick.

  --time sequoia (Not signed in).....Sat Jun 05 17:33:13 -0700 2010

Anybody know how to get this working on windows? Tried both on my laptop and my stationary running xp and vista. What version to use of, Ruby, Rails, all the gems, mysql? I've tried around 8 times with different versions. Those times I got it up and running I still had 2 problems. One what NoMethodNamed errors with an "internal_server_error" in the debug window. Another problem was that when editing the cards I just got a lot of html junk with a couple of references to tinyMCE in it and I wasn't able to edit anything.


Anyone know exactly what version of Ruby, ALL of the gems and mysql to get and have a working Wagn?


Currently i'm running with the following setup:




Ruby 1.8.7


MySQL 5.0 (latest 5.0 build).



  --Søren Enevoldsen (Not signed in).....Sun Jul 18 10:14:15 -0700 2010

Hi Søren,


The html issue is likely to be a problem with the rails version. They introduced an html escaping bug in 2.3.6 and I'm not sure it's been entirely worked out. You might try 2.3.5. The other error ("internal server error") is too vague; could you review the log files to see if there is more information?

  --Ethan McCutchen.....Wed Jul 21 11:18:15 -0700 2010

Thank you very much Ethan. I uninstalled rails and it dependencies and reinstalled version 2.3.5. I don't seem to be having any problems anymore; card creation and editing seems to work now.

  --Søren Enevoldsen (Not signed in).....Thu Jul 22 07:28:16 -0700 2010

Awesome! Do you have any suggestions for how to make the process more friendly for Windows users? Any updates to the installation documentation, for example? Not everyone will be as persistent as you were!

  --Ethan McCutchen.....Thu Jul 22 09:21:13 -0700 2010

Unfortunately not everything works.


I was not able to get image uploading to work. I also got some "error" screen, typically a responder when I used Wagn wrong, think I attempted to make a "basic" card with Recipe+*type+*content and I got an error screen due to me using "basic". Maybe that was intentional in development. Beside the image uploading it worked when I used Wagn the right way,


I tried switching to production mode by following the steps in the installation and it did seem to speed things up a little. I found this piece in this card: "ruby script/server -e production", however then I "found a hitch in Wagn", and it seems I broke it, I now get "ecaptcha::RecaptchaError in Card#open


Showing app/views/views/_open.rhtml where line #14 raised:


No public key specified." on some cards.


I have experience with some various other programming languages but nothing on Ruby (or Rails), but Wagn seems so unique so guess(ed) I can live with it. I do not know what the best way to improve the installation documentation for windows is, I just know that I found it very lacking. Tried multiple times with different versions of most of the gems and mysql to get it working. Ruby 1.9x doesn't seem to work.


Some kind of version listing of the gems and Wagn and Ruby that is known to work together would be nice.

Better info on how to switch to development maybe?

  --Søren Enevoldsen (Not signed in).....Thu Jul 22 13:16:08 -0700 2010

Sigh, I delete my Wagn folder due to the problem I created. I downloaded from the link in Quick Start here. I made a one liner card called "Introduction" and made a link in the right side menu. When I click on that link I get an error:


NoMethodError in Card#show


Showing app/views/layouts/application.html.erb where line #32 raised:


You have a nil object when you didn't expect it!

You might have expected an instance of Array.

The error occurred while evaluating nil.+


Extracted source (around line #32):


29: <% @lay_card = layout_card(@lay_content) %>

30: <% end %>


32: <%= render_layout_card(@lay_card) %>


RAILS_ROOT: C:/Programmering/wagn

Application Trace | Framework Trace | Full Trace


C:/Programmering/wagn/vendor/gems/uuid-2.3.0/lib/uuid.rb:278:in `next_sequence'

C:/Programmering/wagn/vendor/gems/uuid-2.3.0/lib/uuid.rb:307:in `open_lock'










Show session dump











However, When I then F5 it would be good again. F5 bad. F5 good....... Now that I came to post here "this" seems to work fine all the time.


Another thing that has happened to me, always I think, is that it seems Wagn is not able to create the caches. An example of the one page debug information per load/refresh:


Couldn't create cache directory: localhost:3000/development/set-5d2ca490-77fb-012d-d82b-001f1f21f601/*google_analytic_key (cannot generate tempfile `c:/Programmering/wagn/tmp/cache/*google_analytic_key3288-9.cache')

  --Søren Enevoldsen (Not signed in).....Thu Jul 22 13:31:58 -0700 2010

Attempting to enter the config card result in an error similar to above. This is always fail however.

  --Søren Enevoldsen (Not signed in).....Thu Jul 22 13:34:50 -0700 2010

Woof, sorry about all the issues. A few comments:


1. There's nothing wrong with Recipe+*type+*content being Basic. In fact it probably should be basic.

2. The captcha issues look to me like you need to register for a key: If you don't want to do all that, you should be able to turn captcha off by editing the "*all+*captcha" card. I'd be surprised if many others haven't run into this :(

3. The cache issues may be a permissions issue. Check to make sure that the user running the script can write to /tmp/cache (you might start by making it open-writable to make sure this is the problem)

4. The server errors look to me like they might be related to the cache problem, but if not the first place I'd look is at the uuid gem. I don't have a great suggestion for how to figure that out right away, but I'm hoping I can do a windows installation next week to see if I can help smooth out this process.

  --Ethan McCutchen.....Fri Jul 23 12:55:19 -0700 2010

Hi im try to deploy wagn on a centos 5.5 machine using apache passenger mod. I have everything installed and working properly... I think. My question is this i point passenger to the public directory and then navigate to i get redirected to and then nothing. If i run ./scripts/server -e production -d and then restart everything i get redirected to the admin setup page and everything works alright except it still shows the port in the address. Im an used to doing similar setups for other rails applications and it seems like in this case passenger working the way its supposed to and apache is more of a proxy then the thing launching the application. Is there something that i can change so that i don't have to run the webbrick server?





  --booginga (Not signed in).....Wed Aug 11 13:56:19 -0700 2010


I followed INSTALL instructions, which left me with only a partially working wagn because attachment_fu was not pulled in. I figured out from this page that I needed to pull in the submodules, but I don't see where in the install process this is supposed to be happen. grep -r submodule * says the only "submodule" match is in script/, and the only reference to that file is in the Cruise Control build file. This happened on Debian 6, after I had successfully installed from scratch on Lion.


Is this expected behavior, do the INSTALL docs need to be updated, or am I missing something? I'm happy to contribute.

  --xaritas.....Tue Sep 27 10:13:56 -0700 2011

did you do an installation from git (option B)? If so, then this is supposed to happen in step 3 ("get the plugins") with the command `git submodule update --init`.


If you used option A, the submodules should be wrapped in.

  --Ethan McCutchen.....Tue Sep 27 11:02:10 -0700 2011

Ah, okay. I was using option B following the instructions in the INSTALL file. I see they are present on the wiki page.

  --xaritas.....Tue Sep 27 14:17:43 -0700 2011


I figured out from this page that I needed to pull in the submodules, but I don't see where in the install process this is supposed to be happen. grep -r submodule * says the only "submodule" match is in script/, and the only reference to that file is in the Cruise Control build file.

  --manytech.....Tue Nov 22 13:12:32 -0800 2011

I don't have a great suggestion for how to figure that out right away, but I'm hoping I can do a windows installation next week to see if I can help smooth out this process.

  --manytech.....Tue Nov 22 15:37:01 -0800 2011

I'm using wagn 1.11.x with MRI ruby 2.0.0 and it works fine.

--Brett Neumeier.....2013-07-03 17:18:02 +0000